Page 1 of 1

NEW MSRX question

New postPosted: Fri Feb 01, 2013 9:30 pm
by Juice™
This is my first time flyeing Helo's. picked up a BRAND NEW Blad MSRX. Using my DX6i, everytime I take off the Helo takes off to the left. Tried triming it with little success. I know it's something simple... looking for HELP

Re: NEW MSRX question

New postPosted: Fri Feb 01, 2013 10:23 pm
by nunyabizniss34
All helis will want to go left on takeoff due to the rotational torque of the main rotor. Are you trying to take off slowly? If so, pop it up in the air quickly and it should go into a stable hover.

If not, initialize the heli and let it sit on the ground without moving the sticks. Check that the swashplate is level, if it isn't, it will want to go in the direction in which the swashplate tilts. To level it, lengthen or shorten the rods from the servos to the swashplate until it's flat and level. Report back with results :)

Re: NEW MSRX question

New postPosted: Fri Feb 01, 2013 10:27 pm
by nunyabizniss34
Oh one more thing...set your trim tabs to center before you level the swash. Also, don't use trims with a flybarless heli like the MSRX, the flybarless controller see this trim as stick input and it messes it up. Once you level the swash, no trim is needed anyway. Good luck.

Re: NEW MSRX question

New postPosted: Fri Feb 01, 2013 11:48 pm
by RocketManRC
It's almost impossible to tell if a heli is setup properly by trying to fly it when you are just starting as there are so many things happening that are unfamiliar.

I'll be at the indoor flying tomorrow evening and can check it out for you if you are going (and you bring it). Otherwise find a way to get someone experienced to test it for you.

I'm not disagreeing with Colin, I'm just saying that even after confirming it is all setup mechanically it is best to get someone to test it.

Rick

Re: NEW MSRX question

New postPosted: Sat Feb 02, 2013 11:56 am
by Juice™
I'll be there with Bells and My EMBER 2