Multiplex Mentor

Discussions related to training models.

Re: Multiplex Mentor

New postby Enforcer on Thu Oct 15, 2009 8:59 pm

The extra screws and other mods did not work. I read somewhere else that if you don't use the suggested motor, than the "down thrust" may have to be reduced or taken out all together... I took it out all together and it sounds much quiter (on the bench). We'll see if that is the case in flight this weekend.
Murray Wheten

“My philosophy, like color television, is all there in black and white”
Monty Python
User avatar
Enforcer
 
Posts: 1229
Joined: Fri Apr 10, 2009 4:58 pm

Re: Multiplex Mentor

New postby Enforcer on Thu Oct 15, 2009 9:20 pm

Here is an RCUniverse review of the Mentor...

http://www.rcuniverse.com/magazine/arti ... le_id=1062

Go to the bottom of the page and watch the "Acrobatic" video... "listen carefully"... does the sound you hear in the video remind you of the sound you heard coming from "my" Mentor last Saturday? Mine was a bit louder for sure, but similar to this one.
Murray Wheten

“My philosophy, like color television, is all there in black and white”
Monty Python
User avatar
Enforcer
 
Posts: 1229
Joined: Fri Apr 10, 2009 4:58 pm

Re: Multiplex Mentor

New postby Enforcer on Tue Oct 20, 2009 7:14 pm

I sent an e-mail to Mutiplex with my concerns about the "vibration" problem. Following that was their "canned" response... why even bother?

------------------------------------------------------------------

Hi folks!

First off I want to thank you for making such great planes. The Mentor is my second from your line-up; I also have the EasyStar... who doesn't own an EasyStar? :D

Anyway, I was wondering if you have any suggestions as to how I can get the motor mount assembly to vibrate less. As I am sure you are aware by now, this has been reported on several sites. I found what I thought were some solutions, but they turned out not be a "total" solution. The Mentor still sounds a bit like one of those small import cars with "those" huge baffled mufflers (farooommm, faroooooom) once I push the throttle past the halfway mark

Just so you know, I always balance my props and I always use APC E props. I have tried 3 different motors as well, so I am pretty sure the problem is with the design of the motor mount.

Any help you can offer would be very much appreciated! Thanks in advance for you response!
Here is a link to the motor I am using presently, and the next link is to the ESC I am using...
http://www.hobbycity.com/hobbycity/stor ... oduct=2139
http://www.hobbycity.com/hobbycity/stor ... Controller

Also, I am using an APC E 11x5.5 prop and the numbers I get with this combo (on the bench) is 42 Amps and 440 Watts (the motor is rated at 505 Watts)

Thanks!

Murray Wheten

----------------------------------------------------------------------------------------------------------

Hello Murray,

Thank you for choosing Multiplex products. We have found that tightening the motor mount bolts that attach the plate to the frame as tight as possible reduces the vibrato noise dramatically.

Thank you,

Billy Tompkins
Customer Service Rep.
Hitec RCD, LLC
Multiplex USA
Phone (858) 748- 8440
Fax (858) 859-2618
12115 Paine St.
Poway CA, 92064
Murray Wheten

“My philosophy, like color television, is all there in black and white”
Monty Python
User avatar
Enforcer
 
Posts: 1229
Joined: Fri Apr 10, 2009 4:58 pm

Re: Multiplex Mentor

New postby astroflyer on Tue Oct 20, 2009 7:24 pm

are you using a spinner Murray? If so, try it without a spinner and check for vibration. One of my models has a big problem with vibration while running a spinner and none whatsoever without the spinner.

dubro makes a prop balancer which can also balance spinners.
astroflyer
 
Posts: 705
Joined: Tue Jan 27, 2009 6:14 pm

Re: Multiplex Mentor

New postby Enforcer on Tue Oct 20, 2009 7:33 pm

Hi Al!

Spinner, no spinner, 3 different motors, 3 difference sized "balanced" props... it makes no difference. :( Oh well!
Murray Wheten

“My philosophy, like color television, is all there in black and white”
Monty Python
User avatar
Enforcer
 
Posts: 1229
Joined: Fri Apr 10, 2009 4:58 pm

Re: Multiplex Mentor

New postby shimsham on Mon Jun 14, 2010 4:31 pm

Hi Guys. I am having trouble getting a Turnigy Sk 3548-900kv motor to fit on the motor mount,first only two holes line up and secondly when you give the motor a little throttle the motor starts making one hell of noise like it hitting the rear of the motor mount,took the motor off the motor mount to try it and gave it just a little throttle and it just locked up and then it tried to wrap the cables round the can,
Anyone tell me a suitable motor for this model.


Regards Colin
shimsham
 
Posts: 1
Joined: Wed Apr 28, 2010 11:15 am

Previous

Return to Trainers

Who is online

Users browsing this forum: No registered users and 1 guest